Qmatic Experience Cloud - EU Region - Slowness and Booking Errors

Incident Report for Qmatic

Resolved

This incident has been resolved.
Posted Aug 25, 2026 - 06:17 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 24, 2026 - 12:55 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 24, 2026 - 12:54 UTC

Investigating

We are currently aware of issues that maybe affecting your system. Our team is actively investigating the root cause and working to resolve the issue as quickly as possible.

During this time, you may experience problems such as slowness working around the system or error message icons appearing. We apologize for any inconvenience caused and will provide further updates as soon as more information becomes available.

Thank you for your patience and understanding.
Posted Aug 24, 2026 - 11:57 UTC
This incident affected: Experience Cloud [qmatic.io] (Europe).