Qmatic Experience Cloud (US)

Scheduled for Dec 9, 09:00 - 12:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Dec 03, 2025 - 16:37 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Dec 03, 2025 - 10:07 UTC

Scheduled

We would like to inform you that we will be performing maintenance on the Qmatic Experience Cloud platform.

When will the maintenance take place?
The maintenance is scheduled for Tuesday, December 9th, from 4 AM to 7 AM EST.

Will this affect my current setup?
During this time, the Qmatic Experience Cloud applications related to managing visits (Check-In, Serve, Monitor Operations, Reports) will be temporarily unavailable. However, your booking capabilities will remain operational, and your customers will be able to book appointments as usual.

What is included in this update?
The following list does not contain all items, but release highlights, a selection of relevant items regarding the update:

Serve performance improvements: instant updates on the number of waiting tickets in the queue
Check-in: option to make marks mandatory.

Read more about the updates here.

For more information, please contact our Product & Support teams.

Sincerely,
The Qmatic Team
Posted Dec 03, 2025 - 09:35 UTC
This scheduled maintenance affects: Experience Cloud [qmatic.io] (United States).