Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 20, 2026 - 11:00 UTC
Scheduled
We would like to inform you that we will be performing maintenance on the Qmatic Experience Cloud platform.
When will the maintenance take place? The maintenance is scheduled for Wednesday, May 20th, from 11 AM to 11:59 AM UTC.
Will this affect my current setup? During this time, the Qmatic Experience Cloud applications related to managing visits (Check-In, Serve, Monitor Operations, Reports) will be temporarily unavailable. However, your booking capabilities will remain operational, and your customers will be able to book appointments as usual.
Sincerely, The Qmatic Team
Posted May 19, 2026 - 07:45 UTC
This scheduled maintenance affected: Experience Cloud [qmatic.io] (United States).